Vés al contingut (premeu Retorn)

Sou a: Inici / Còpies de seguretat / Documentació / Manuals d'instal·lació del client / Instal·lació i reinstal·lació del client en Debian i Ubuntu

Instal·lació i reinstal·lació del client en Debian i Ubuntu


Instal·lació del client

1. En primer lloc descarregueu el paquet de Legato Networker per a la vostra versió de sistema operatiu (Debian o Ubuntu) des de la web de distribució de software.

2. Al terminal, executeu la comanda per instal·lar el paquet descarregat:

$ sudo dpkg -i lgtoclnt_XXX.deb

 

3. En el cas de que apareguin errors de dependències, com per exemple:

Unpacking lgtoclnt (from lgtoclnt_8.1_i386.deb) ...
dpkg: dependency problems prevent configuration of lgtoclnt:
lgtoclnt depends on ksh | pdksh; however:
Package ksh is not installed.
Package pdksh is not installed.
lgtoclnt depends on libstdc++5; however:
Package libstdc++5 is not installed.
lgtoclnt depends on libxp6; however:
Package libxp6 is not installed.
dpkg: error processing lgtoclnt (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
lgtoclnt

 

   Cal executar la següent comanda per instal·lar els paquets necessaris:

$ sudo apt-get -f upgrade

   En executar la comanda apt-get, es completarà automàticament la instal·lació fallida del client de Networker.

Si tot i així fallés, hauriem de desinstal·lar el software:

        $ sudo apt-get remove --purge lgtoclnt

I instal·lar primer la llibreria que ens demana:

        $ sudo wget http://ftp.es.debian.org/debian/pool/main/libx/libxp/libxp6_1.0.2-2_amd64.deb

        $ sudo dpkg -i libxp6_1.0.2-2_amd64.deb

        $ sudo dpkg -i lgtoclnt_XXX.deb


4. Comproveu que el procés nsrexecd s'estigui executant: 

$ ps -ef | grep nsrexecd

5. En cas que no s'estigui executant, inicieu manualment el procés amb la comanda: 

$ sudo /etc/init.d/networker start

Per a obtenir informació més detallada, podeu descarregar-vos el manual d'instal·lació del web del fabricant de software.

Reinstal·lació o actualització del client

Per reinstal·lar o actualitzar la versió del client de Networker heu d'executar les accions següents:

1. Atureu el servei de Networker si s'està executant: 

$ /etc/init.d/networker stop

2. Desinstal·leu els paquets de Networker:

$ sudo apt-get remove lgtoclnt, lgtoman

3. Esborreu tot el directori d'instal·lació del client per eliminar els arxius temporals, certificats,...

$ sudo rm -r /nsr

4. Instal·leu la versió de client de Networker 18.1. La darrera versió disponible està a la web de distribució de software.